No UEFI boot for 8.10 Testing

General discussion forum for Parsix GNU/Linux in English.

Moderators: aysabzevar, mandog, alan, bkashaf, xet7, cmost, blix

No UEFI boot for 8.10 Testing

Postby bokoto » Tue Mar 29, 2016 1:05 am

I have been trying to boot from uefi using the x 64 iso image provided on the website. It seems it does not work for some reason. I tried burning with 3 different tools and it is all the same - cant boot. Rufus tells me this is not a uefi image. I wonder what could be wrong. there are 2 files in the efi folder : core.efi and grub.efi - both drop me into grub rescue shell
bokoto
 
Posts: 5
Joined: Tue Mar 29, 2016 12:49 am

Re: No UEFI boot for 8.10 Testing

Postby alan » Wed Mar 30, 2016 3:14 pm

Thanks for reporting this issue. I will look into it and will get back to you. Have you tried the 8.5 ISO in UEFI mode?
alan
Developer
Developer
 
Posts: 763
Joined: Tue Jan 25, 2005 7:13 am
Location: Santa Clarita, California

Re: No UEFI boot for 8.10 Testing

Postby bokoto » Wed Mar 30, 2016 4:13 pm

alan wrote:Thanks for reporting this issue. I will look into it and will get back to you. Have you tried the 8.5 ISO in UEFI mode?


No, haven't tried it - I am particularly interested in Gnome 3.20.
bokoto
 
Posts: 5
Joined: Tue Mar 29, 2016 12:49 am

Re: No UEFI boot for 8.10 Testing

Postby alan » Wed Mar 30, 2016 5:11 pm

I confirm the issue exists. If you really need UEFI now, you can use a 8.5 ISO and dist-upgrade to 8.10. We will fix this issue with TEST-1.
alan
Developer
Developer
 
Posts: 763
Joined: Tue Jan 25, 2005 7:13 am
Location: Santa Clarita, California

Re: No UEFI boot for 8.10 Testing

Postby bokoto » Wed Mar 30, 2016 7:09 pm

alan wrote:I confirm the issue exists. If you really need UEFI now, you can use a 8.5 ISO and dist-upgrade to 8.10. We will fix this issue with TEST-1.


Unfortunately the same issue occurs with 8.5 as well. Same outcome - landing me in grub rescue mode.Unless I am doing something wrong, which I highly doubt. Maybe I should also add that I run on GPT if that makes any difference.
bokoto
 
Posts: 5
Joined: Tue Mar 29, 2016 12:49 am

Re: No UEFI boot for 8.10 Testing

Postby alan » Wed Mar 30, 2016 7:36 pm

That is strange. 8.5r0 ISO boots just fine with UEFI in my environment. For initial live disk boot, you really do not need to have a GPT disk.

May I ask what kind of system are you trying to run the ISO on?
alan
Developer
Developer
 
Posts: 763
Joined: Tue Jan 25, 2005 7:13 am
Location: Santa Clarita, California

Re: No UEFI boot for 8.10 Testing

Postby bokoto » Wed Mar 30, 2016 8:03 pm

alan wrote:That is strange. 8.5r0 ISO boots just fine with UEFI in my environment. For initial live disk boot, you really do not need to have a GPT disk.

May I ask what kind of system are you trying to run the ISO on?


HP 2530p : Core2Duo SL 9600, GPU Intel 4500 HD, Nothing unusual - it is a bit old but today i ve tested uefi on Fedora 24, and on the Debian part : Sparky 4.3 and Cub Linux. They all boot up fine.

P.S. A clue : Rufus throws an alert when i select UEFI target mode saying this is not a uefi image - I have no idea wheteher this is a valid clue but for example this didnt happen with the other distros i ve tested.
bokoto
 
Posts: 5
Joined: Tue Mar 29, 2016 12:49 am

Re: No UEFI boot for 8.10 Testing

Postby alan » Wed Mar 30, 2016 9:42 pm

OK, did you burn the ISO or created a bootable USB using rufus? The way Parsix's live boot works, it is not compatible with regular usb-bootable media creators.

Download this script to create a USB based media:

http://www.parsix.org/browser/pkg/offic ... ix-iso2usb
alan
Developer
Developer
 
Posts: 763
Joined: Tue Jan 25, 2005 7:13 am
Location: Santa Clarita, California

Re: No UEFI boot for 8.10 Testing

Postby alan » Wed Mar 30, 2016 9:49 pm

The only issue is the script will create a BIOS based bootable image 8)
alan
Developer
Developer
 
Posts: 763
Joined: Tue Jan 25, 2005 7:13 am
Location: Santa Clarita, California

Re: No UEFI boot for 8.10 Testing

Postby bokoto » Thu Mar 31, 2016 1:46 am

alan wrote:The only issue is the script will create a BIOS based bootable image 8)


Thanks - however I will pass on that one - I have a UEFI system and would like to boot UEFI media as well...not having to deal with the imminent woes of having BIOS install on a UEFI machine. FYI - I have burnt at least 10-12 different iso's with Rufus, LIveLinux and Rawrite and they all boot to uefi. Just my 5 cents. :)
Thanks for your effort.
bokoto
 
Posts: 5
Joined: Tue Mar 29, 2016 12:49 am

Re: No UEFI boot for 8.10 Testing

Postby alan » Thu Mar 31, 2016 2:29 am

OK, Status update, UEFI boot works if you burn the ISO on a DVD. This is the only solution for now. I'll work on a solution for UEFI USB.
alan
Developer
Developer
 
Posts: 763
Joined: Tue Jan 25, 2005 7:13 am
Location: Santa Clarita, California


Return to General Discussions - English

Who is online

Users browsing this forum: No registered users and 2 guests

cron