[SOLVED] cups / printing problem in Parsix 1.5

User created HOW-TOs, guides and workarounds.

Moderators: aysabzevar, mandog, alan, bkashaf, xet7, cmost, blix

[SOLVED] cups / printing problem in Parsix 1.5

Postby nomadic » Fri Jul 04, 2008 9:58 am

CUPS is not running as a service, even tho the various CUPS packages are installed.
I cannot add my usb printer using system/administration/printing - I get the error message There was an error during the CUPS operation: 'httpConnectionEncrypt failed'.
If I try using applications/Parsix/Printer Manager, I get the message "IceWeasel cant establish connectivity with localhost:631.
I get this last message also if I try to connect th http://localhost:631 through Iceweasel directly.

Is this just because CUPS is not running, and if so, how can I get it to run please?

nomadic
Last edited by nomadic on Sun Jul 06, 2008 9:46 am, edited 1 time in total.
nomadic
 
Posts: 4
Joined: Fri Jul 04, 2008 9:34 am

Postby cmost » Fri Jul 04, 2008 1:34 pm

I noticed this problem too, which also, by the way, affects NFS services (meaning that NFS shares are not automatically mounted at boot because the NFS services are not running.)

To solve your problem, simply add the following two commands BEFORE the last line in /etc/rc.local (Note: You must edit rc.local as root.)

At the command line:
sudo gedit /etc/rc.local

add...
sleep 20
/etc/init.d/cups restart
...before the last line...

save the file
restart the computer

CUPS should start at each boot now. Good luck!
cmost
Forum Moderator
Forum Moderator
 
Posts: 212
Joined: Tue Feb 19, 2008 4:16 am
Location: Cincinnati, Ohio

Postby nomadic » Fri Jul 04, 2008 1:59 pm

Hi cmost
thank you for the quick reply.

good news and bad news
the bad news is that the edit has had no effect and cups does not start.:
the good news is that your reply gave me the info to restart CUPS manually (/etc/init.d/cups restart). I manually started cups and set up my printer ok.

So the urgency is gone but I would still like to have cups starting automatically.

In case I have done something wrong, the contents of /etc/rc.local after the edit are as follows

#!/bin/sh -e
#
# rc.local
#
# This script is executed at the end of each multiuser runlevel.
# Make sure that the script will "exit 0" on success or any other
# value on error.
#
# In order to enable or disable this script just change the execution
# bits.
#
# By default this script does nothing.
sleep 20
/etc/init.d/cups restart

exit 0

nomadic
nomadic
 
Posts: 4
Joined: Fri Jul 04, 2008 9:34 am

Postby cmost » Fri Jul 04, 2008 2:25 pm

Hmmm... adding the two aforementioned lines to your rc.local file should indeed force CUPS to restart at each boot. On the other hand, if your rc.local file is not executable, then it may not execute. In a terminal, as root, execute the following:

sudo chmod a+x /etc/rc.local

Beyond that, I'm not sure why the contents of your rc.local file are not being executed. You could always add the cups command to your Gnome session manager... :-) A dirty way to do it but it probably would work nonetheless. Keep me posted on your progress. Other users will no doubt benefit.
AMD Phenom II 64 X6 1090T Black Edition Hexa-Core
8192 MB DDR2 RAM
nVidia GeForce GTX 660 w 2048 MB DDR5
Linux Mint Debian Edition 64 Bit
Parsix (Debian Testing) GNU/Linux 64 Bit
Liquorix Kernel 3.12.x
cmost
Forum Moderator
Forum Moderator
 
Posts: 212
Joined: Tue Feb 19, 2008 4:16 am
Location: Cincinnati, Ohio

Postby nomadic » Fri Jul 04, 2008 5:08 pm

hi cmost

chmod made no difference, although something has changed.

After boot,
- cups does not appear in system/adminintration/services.
- Going to system/administration/printing still fails (not connecting)
- going to applications/Parsix/printer manager DOES work (connects to localhost) BEFORE I manually start cups
- From the browser I can go directly to localhost:631 BEFORE I manually start cups

(I still have those two lines in /rc.local)

I included the command "/etc/init.d/cups restart" as a start-up job in system/preferences/sessions but it is not starting cups.

I can carry on starting cups manually but I would like to find out why this is necessary.

nomadic.
nomadic
 
Posts: 4
Joined: Fri Jul 04, 2008 9:34 am

Postby cmost » Fri Jul 04, 2008 6:43 pm

Have a look at this page... It will assist you in creating a script to start (or stop) the CUPS service manually. I am thinking about using this method to create a few custom scripts myself. Good luck!

http://www.debian-administration.org/articles/28
AMD Phenom II 64 X6 1090T Black Edition Hexa-Core
8192 MB DDR2 RAM
nVidia GeForce GTX 660 w 2048 MB DDR5
Linux Mint Debian Edition 64 Bit
Parsix (Debian Testing) GNU/Linux 64 Bit
Liquorix Kernel 3.12.x
cmost
Forum Moderator
Forum Moderator
 
Posts: 212
Joined: Tue Feb 19, 2008 4:16 am
Location: Cincinnati, Ohio

Postby alan » Fri Jul 04, 2008 8:25 pm

Simply use the following command to enable cups at boot:

Code: Select all
# ln -s /etc/init.d/cups /etc/rc5.d/S99cups


cups service name has changed from cupsys to cups, the installer system needs to be updated. will be fixed in Viola r1.
alan
Developer
Developer
 
Posts: 763
Joined: Tue Jan 25, 2005 7:13 am
Location: Santa Clarita, California

Solved - cups not starting at boot

Postby nomadic » Sat Jul 05, 2008 9:12 am

alan
that solved the problem.
thanks for your help and also to cmost

nomadic
nomadic
 
Posts: 4
Joined: Fri Jul 04, 2008 9:34 am

RE: Solved - cups not starting at boot

Postby cmost » Sat Jul 05, 2008 1:21 pm

Alan is the boss!
@nomadic, can you mark this topic as [solved]?
AMD Phenom II 64 X6 1090T Black Edition Hexa-Core
8192 MB DDR2 RAM
nVidia GeForce GTX 660 w 2048 MB DDR5
Linux Mint Debian Edition 64 Bit
Parsix (Debian Testing) GNU/Linux 64 Bit
Liquorix Kernel 3.12.x
cmost
Forum Moderator
Forum Moderator
 
Posts: 212
Joined: Tue Feb 19, 2008 4:16 am
Location: Cincinnati, Ohio

RE: Solved - cups not starting at boot

Postby bartos » Thu Aug 14, 2008 9:18 pm

Alan's post of
Code: Select all
# ln -s /etc/init.d/cups /etc/rc5.d/S99cups
solved my problem.

Thanks
bartos
 
Posts: 1
Joined: Thu Aug 14, 2008 9:16 pm

Postby mandog » Fri Aug 15, 2008 8:20 am

Just a foot note cups is back on track on 1,5r1
Parsix running AMD FX(tm)-6100 Six-Core Processor, Gigabyte mother board 8gb ram, Nvidia graphic card 1gb unboard ram, Plextor PX760, EPSON R300, 2x 500gb hds, sata+3x 500gb, 1x2tb Hardrives, 23" AOC monitor 1980X1080 Resolution
mandog
Forum Moderator
Forum Moderator
 
Posts: 483
Joined: Fri Jan 25, 2008 3:08 pm
Location: Peru


Return to HOW-TOs - English

Who is online

Users browsing this forum: No registered users and 1 guest