autostart compiz

User created HOW-TOs, guides and workarounds.

Moderators: aysabzevar, mandog, alan, bkashaf, xet7, cmost, blix

autostart compiz

Postby lawmanuk » Fri Aug 08, 2008 10:33 pm

i manage to start compiz by running the compiz fusion icon and then restarting window manager.

the problem is that i have to do this on each pc start.

is there an auto way for this to happen every time?

thanks
lawmanuk
Parsix Lover
 
Posts: 148
Joined: Fri Aug 08, 2008 7:34 pm

RE: autostart compiz

Postby cmost » Fri Aug 08, 2008 11:45 pm

Yes! Navigate to System --> Preferences --> Sessions
Click the 'Add' button
Fill out the dialog:
Name: Compiz-Fusion 3D desktop (or whatever you like)
Command: fusion-icon
Comment: Enable dazzling 3D effects (or leave it blank, whatever.)

This will autostart Fusion-icon (and thus Compiz-fusion) for every session!

Another way to do this (a better way) in my opinion, is to create a little shell script designed so that Compiz-fusion is the last thing to start. This prevents weird visual anomalies from occurring as Compiz-fusion and other services / applications try to start at the same time. To do this:

1. Create a new text file...
Copy and paste the following...
#!/bin/bash
killall fusion-icon
killall emerald
sleep 12s
fusion-icon

Note: The sleep command forces a 12 second pause before the fusion-icon command is issued. You can change this to anything.
Save the file as Start-compiz-fusion
Right-click the file and select 'properties' then the 'permissions' tab
tick the box for "allow executing of file as program"
Browse for this file in place of the raw 'fusion-icon' command in the above instructions.

In either case, Compiz-fusion will start at each session. Enjoy!
AMD Phenom II 64 X6 1090T Black Edition Hexa-Core
8192 MB DDR2 RAM
nVidia GeForce GTX 660 w 2048 MB DDR5
Linux Mint Debian Edition 64 Bit
Parsix (Debian Testing) GNU/Linux 64 Bit
Liquorix Kernel 3.12.x
cmost
Forum Moderator
Forum Moderator
 
Posts: 212
Joined: Tue Feb 19, 2008 4:16 am
Location: Cincinnati, Ohio

RE: autostart compiz

Postby grasshopper » Sat Aug 09, 2008 2:56 am

Never saw the last bit before. Thanks for the info.
grasshopper
 
Posts: 28
Joined: Thu Aug 07, 2008 2:51 pm

RE: autostart compiz

Postby alan » Sat Aug 09, 2008 8:52 am

There is a better way:

Applications -> System Tools -> Configuration Editor

Navigate to: /desktop/gnome/applications/window_manager/

Change "current" and "default" values to /usr/bin/compiz

This would be faster and does not cause delays. Because, compiz is directly loaded and not after loading metacity.
alan
Developer
Developer
 
Posts: 763
Joined: Tue Jan 25, 2005 7:13 am
Location: Santa Clarita, California

RE: autostart compiz

Postby cmost » Sat Aug 09, 2008 1:39 pm

Hey, awesome! I didn't know about starting Compiz that way! Thanks!
AMD Phenom II 64 X6 1090T Black Edition Hexa-Core
8192 MB DDR2 RAM
nVidia GeForce GTX 660 w 2048 MB DDR5
Linux Mint Debian Edition 64 Bit
Parsix (Debian Testing) GNU/Linux 64 Bit
Liquorix Kernel 3.12.x
cmost
Forum Moderator
Forum Moderator
 
Posts: 212
Joined: Tue Feb 19, 2008 4:16 am
Location: Cincinnati, Ohio

RE: autostart compiz

Postby grasshopper » Sun Aug 10, 2008 4:02 am

I didn't know that either. Cool.And I don't even use Compiz.
grasshopper
 
Posts: 28
Joined: Thu Aug 07, 2008 2:51 pm

RE: autostart compiz

Postby lawmanuk » Sun Aug 10, 2008 7:12 pm

i'm getting errors with this solution. when i restart the computer, compiz doesn't start, and the windows don't have borders.

to fix this i have to restart the window with the compiz icon.

any solution?
lawmanuk
Parsix Lover
 
Posts: 148
Joined: Fri Aug 08, 2008 7:34 pm

Postby lawmanuk » Wed Sep 03, 2008 11:28 pm

just checking if anyone's figured out why compiz messes up spasmodically, with no borders - until window manager reloaded.

seems to happen more on some machines than others. :(
lawmanuk
Parsix Lover
 
Posts: 148
Joined: Fri Aug 08, 2008 7:34 pm

Postby alan » Thu Sep 04, 2008 1:03 am

For me it happens very rarely.
alan
Developer
Developer
 
Posts: 763
Joined: Tue Jan 25, 2005 7:13 am
Location: Santa Clarita, California

Postby st0.0pidn0.0bie » Thu Sep 04, 2008 1:35 am

it happens every time, so i can't even use compiz / compiz fusion icon. must be a laptop driver or ati thing. :-( oh well i guess, more memory is free for programs
st0.0pidn0.0bie
 
Posts: 58
Joined: Thu Jun 26, 2008 12:09 am

Postby lawmanuk » Sun Sep 07, 2008 10:49 am

i was finding a lot of noborder problems when compiz was started from the configuration editor as per alan's suggestion above.

i even found that sometimes, compiz wouldn't start this way and metacity was still loading... but still noborder problems.

i've put the configuration editor setting back to metacity, and now start compiz from pref/sessions.

this seems to have removed the noborder problems... so far at least.

(ps. not sure if this is because it reloads the window manager after start?)

:)
lawmanuk
Parsix Lover
 
Posts: 148
Joined: Fri Aug 08, 2008 7:34 pm


Return to HOW-TOs - English

Who is online

Users browsing this forum: No registered users and 1 guest

cron