How to disable inputing Iran language?

User created HOW-TOs, guides and workarounds.

Moderators: aysabzevar, mandog, alan, bkashaf, xet7, cmost, blix

How to disable inputing Iran language?

Postby yingwuzhao » Sun Sep 14, 2008 12:59 am

When you press "left Ctr + Left Shift" when typing, you will be swithed to Iran input. And there is no way to diable it!

I went to Preference > Keyboard > Layout, diabled Iran Keyboard layout, and went to "Layout Option" to disable the shortkey for switching Layouts, but I can't diable it!! After I diable it, it will be toggled back.

Because I need to use Emacs, and there are a lot of command that will conflict this "Ctr + Shift", it's really annoying!

Please help me to diable this Iran input and this shortkey for switching input.
yingwuzhao
 
Posts: 44
Joined: Wed Sep 03, 2008 2:23 pm

RE: How to disable inputing Iran language?

Postby arash-m » Sun Sep 14, 2008 10:24 am

If you don't need it, just remove it! Click on "iran" and press "remove" "in "Preference > Keyboard > Layout".
arash-m
 
Posts: 56
Joined: Mon Mar 03, 2008 11:00 pm

Postby yingwuzhao » Mon Sep 15, 2008 2:25 am

Of course, I did it.
After removing it, open a firefox and press "ctr + shift", you will start to input Iran language again! You can't "remove" it at all.

I even tried to edit keyboard layout file in etc somewhere, and then you can not switch to Iran anymore, BUT, after you reboot, the "magic" key "ctr+shift" start working again!! You will see all the strange Iran symbols again.

Obviously, this is a bug! The problem is that you can't disable the magic switching short key!! And you CAN'T delete the Iran keyboard layout, either.

Using Emacs is really important to me, with conflict with this "ctr+shift" short key, there is no way I can "correctly" use Emacs in Parsix. If this tiny small problem is not solved, I will have to switch back to Ubuntu. Someone please help me!
yingwuzhao
 
Posts: 44
Joined: Wed Sep 03, 2008 2:23 pm

Postby arash-m » Mon Sep 15, 2008 12:56 pm

I don't have the problem! What about editing files under "/etc/sysconfig"?
arash-m
 
Posts: 56
Joined: Mon Mar 03, 2008 11:00 pm

Postby yingwuzhao » Mon Sep 15, 2008 3:05 pm

I am sorry, the short key I was talking about is not: ctr+shift but alt+shift.
Try it to see you have the same problem.
yingwuzhao
 
Posts: 44
Joined: Wed Sep 03, 2008 2:23 pm

Postby alan » Mon Sep 15, 2008 3:58 pm

Try to find this section in your /etc/X11/xorg.conf file:

Code: Select all
Section "InputDevice"
    Identifier  "Keyboard0"
    Driver      "kbd"
    Option      "CoreKeyboard"
    Option      "XkbRules"      "xorg"
    Option      "XkbOptions"    "grp:alt_shift_toggle"
    Option      "XkbLayout" "us,ir"
    Option      "XkbModel"      "pc105"

EndSection


Then replace us,ir -> us or what you need :-)
alan
Developer
Developer
 
Posts: 763
Joined: Tue Jan 25, 2005 7:13 am
Location: Santa Clarita, California

Postby yingwuzhao » Tue Sep 16, 2008 12:42 am

Hi, Alan, Thank you very much.

That works, you saved me from Ubuntu!

But there is another small problem: when typing in Iceweasel the "spelling check" doesn't work correctly after I tried "alt+shift" a few times.

It simply underline everywork I type. How to correct it?
yingwuzhao
 
Posts: 44
Joined: Wed Sep 03, 2008 2:23 pm

Postby yingwuzhao » Tue Sep 16, 2008 3:06 am

I got it, simply choose language as English in right click of multi-line editing in Iceweasel.

Thanks everybody, I am still in love in Parsix.
yingwuzhao
 
Posts: 44
Joined: Wed Sep 03, 2008 2:23 pm


Return to HOW-TOs - English

Who is online

Users browsing this forum: No registered users and 1 guest

cron