ATI problem in Parsix Boss

Discussions related to hardware issues, incompatibilities, drivers, etc.

Moderators: aysabzevar, mandog, alan, bkashaf, xet7, cmost, blix

ATI problem in Parsix Boss

Postby Tuchane » Sat Jan 31, 2009 12:56 am

First of all, I would like to thank you for you amazing work! Viola is very good and Parsix Boss is excellent!
But unfortunately I ran into some problems and your help would be appreciated.
On one of my machines I managed to successfully install NVDIALinux x86_64-180.22 for NVDIA 8200 video card using your instructions. It works perfectly fine!
But I couldn't install ATI drivers 8.7, 8.10 and 8.12 on my other machine for radeon HD3870 video card. I tried installing the driver using 4 methods:
1) I tried to use synaptic for installing fglrx-kernel-2.6.26-parsix64-7 but I got an error message saying “the following packages have unresolvable dependancies” and “Depends: fglrx-driver (=1:8-7-3) but 1:8-12-4 is to be installed”. (This is what I have in my /etc/apt/sources.list :
# Debian Testing
# deb http://ftp.us.debian.org/debian testing main contrib non-free
# deb-src http://ftp.de.debian.org/debian testing main contrib non-free

# Parsix
deb http://packages.parsix.org/official/ boss main contrib non-free
deb-src http://packages.parsix.org/official/ boss main contrib non-free
deb http://packages.parsix.org/continent viola main contrib non-free
deb-src http://packages.parsix.org/continent viola main contrib non-free


# Debian Multimedia
deb http://www.debian-multimedia.org testing main )

Then I tried 3 more methods:

2)Then I tried to use ati drivers downlowded from ati official website 8.7,8.10, 8.12 generated for Debian/testing.
3)I also tried to follow the instructions from here http://www.parsix.org/html/pnWikka-tag-AtiHowto.html.
4)And I also tried this command  aticonfig --initial --force taken from here: http://www.parsix.org/html/PNphpBB2-vie ... t-385.html

As a result of using the last 3 methods I mentioned I did install the driver but display redrawing became incredibly slow.
Is there a way to get around this problem?

If you don't mind I would also like to ask you for some advice about setting up accesspoint-router Asus 520 GU in Parsix Viola, because I didn't manage to get it to work in Viola using Network Configuration tool, while it works great in Boss. (I have Parsix Boss and Viola on the same computer)

Thank you very much in advance.
I am looking forward to your reply.
Tuchane
 
Posts: 15
Joined: Sat Jan 31, 2009 12:50 am

RE: ATI problem in Parsix Boss

Postby blix » Sat Jan 31, 2009 7:40 am

Your sources.list is strange. You got repositories of both Viola and Boss altogether. Comment out one of them.
And in case of Asus 520 GU, it might have a web interface with an invalid IP like 192.168.0.1. check it. If it doesn't work begin a new topic for this problem.
Those who sacrifice liberty for security deserve neither.
Benjamin Franklin
blix
Forum Moderator
Forum Moderator
 
Posts: 115
Joined: Tue Jun 19, 2007 9:40 pm

Postby mandog » Sat Jan 31, 2009 8:43 am

Regards your router the best place to go for info is http://portforward.com/routers.htm
If your router is listed you should find info.
Parsix running AMD FX(tm)-6100 Six-Core Processor, Gigabyte mother board 8gb ram, Nvidia graphic card 1gb unboard ram, Plextor PX760, EPSON R300, 2x 500gb hds, sata+3x 500gb, 1x2tb Hardrives, 23" AOC monitor 1980X1080 Resolution
mandog
Forum Moderator
Forum Moderator
 
Posts: 483
Joined: Fri Jan 25, 2008 3:08 pm
Location: Peru

Re: RE: ATI problem in Parsix Boss

Postby Tuchane » Sat Jan 31, 2009 7:29 pm

Thank you very much for your reply!

I commented out Parsix Boss repositories and tried this command apt-get update && apt-get install fglrx-driver fglrx-glx fglrx-control fglrx-kernel-`uname -r`.
The driver is installed now and the resolution is correct. But still everything is working very slowly. Windows redraw very slowly, but video plays fine though.
Tuchane
 
Posts: 15
Joined: Sat Jan 31, 2009 12:50 am

RE: Re: RE: ATI problem in Parsix Boss

Postby alan » Sat Jan 31, 2009 8:44 pm

OK,

I fixed the ATI driver problem, you can install it from repository now.

Alan
alan
Developer
Developer
 
Posts: 763
Joined: Tue Jan 25, 2005 7:13 am
Location: Santa Clarita, California

Re: RE: Re: RE: ATI problem in Parsix Boss

Postby Tuchane » Sat Jan 31, 2009 10:49 pm

Alan, thank you very much for your help!!

Unfortunately, the problem still persists.

I suspect I am making a silly mistake somewhere.

So, this is what my repository list looks like now:

# Debian Testing
# deb http://ftp.us.debian.org/debian testing main contrib non-free
# deb-src http://ftp.de.debian.org/debian testing main contrib non-free

# Parsix Official
deb http://packages.parsix.org/official viola main contrib non-free
deb-src http://packages.parsix.org/official viola main contrib non-free

# Parsix Continent
deb http://packages.parsix.org/continent viola main contrib non-free
deb-src http://packages.parsix.org/continent viola main contrib non-free

# Security
# deb http://security.parsix.org viola main contrib non-free
# deb-src http://security.parsix.org viola main contrib non-free

# Debian Multimedia
deb http://www.debian-multimedia.org testing main

And this is how the command line i type into the terminal looks like:
apt-get update && apt-get install fglrx-driver fglrx-glx fglrx-control fglrx-kernel-2.6.24-parsix64-23

Maybe the name of the kernel I am using is wrong?
Tuchane
 
Posts: 15
Joined: Sat Jan 31, 2009 12:50 am

Postby mandog » Sun Feb 01, 2009 12:16 am

you had both Viola and Boss repro so one would assume that you a using the Boss kernal, so try swaping repros and reinstalling your drivers. Please note some ATI cards do not like open source drivers.
Parsix running AMD FX(tm)-6100 Six-Core Processor, Gigabyte mother board 8gb ram, Nvidia graphic card 1gb unboard ram, Plextor PX760, EPSON R300, 2x 500gb hds, sata+3x 500gb, 1x2tb Hardrives, 23" AOC monitor 1980X1080 Resolution
mandog
Forum Moderator
Forum Moderator
 
Posts: 483
Joined: Fri Jan 25, 2008 3:08 pm
Location: Peru

Postby alan » Sun Feb 01, 2009 8:42 am

Remove Viola lines, keep Boss lines, reset your package data files using:

# rm /var/lib/apt/lists/*
# apt-get update


And go ahead.
alan
Developer
Developer
 
Posts: 763
Joined: Tue Jan 25, 2005 7:13 am
Location: Santa Clarita, California

Postby Tuchane » Fri Feb 06, 2009 11:00 am

Thank you!!
I tried that - kept Boss lines and did it all again. My screen went completely black after loading and I couldn't type in my username and password... As a result I bought nvidia - and it works great. :-)
Tuchane
 
Posts: 15
Joined: Sat Jan 31, 2009 12:50 am

Re: ATI problem in Parsix Boss

Postby bluebird5 » Thu Feb 06, 2014 8:56 am

If you don't mind I would also like to ask you for some advice about setting up accesspoint-router Asus 520 GU in Parsix Viola, because I didn't manage to get it to work in Viola using Network Configuration tool, while it works great in Boss. (I have Parsix Boss and Viola on the same computer Is there a way to get around this problem?
Smile PleazZZZzzzZZZzzzz
bluebird5
 
Posts: 1
Joined: Thu Feb 06, 2014 8:49 am

Re: ATI problem in Parsix Boss

Postby alan » Thu Feb 06, 2014 5:12 pm

Have you ever tried to use a newer version of Parsix? :D
alan
Developer
Developer
 
Posts: 763
Joined: Tue Jan 25, 2005 7:13 am
Location: Santa Clarita, California


Return to Hardware Issues - English

Who is online

Users browsing this forum: No registered users and 1 guest

cron