USB will not mount

Discussions related to hardware issues, incompatibilities, drivers, etc.

Moderators: aysabzevar, mandog, alan, bkashaf, xet7, cmost, blix

USB will not mount

Postby mwp » Tue Jun 03, 2008 10:52 am

I cannot get the usb to mount in 1.5 release #2. So I'm stuck not being able to transfer docs, and stuff, from a previous setup. Can someone help me get this running. I am not a linux expert, but I am not a noob either. Can use the command line and a editor. Just need to know what to do. I have never had this type of problem happen before. Thanks.
mwp
 
Posts: 3
Joined: Tue Jun 03, 2008 10:46 am

RE: USB will not mount

Postby alan » Tue Jun 03, 2008 12:15 pm

Attach your usb stick and send the last 20 lines of dmesg command.
alan
Developer
Developer
 
Posts: 763
Joined: Tue Jan 25, 2005 7:13 am
Location: Santa Clarita, California

USB will not mount

Postby mwp » Tue Jun 03, 2008 4:51 pm

sdb: rw=0, want=4067027080, limit=1005568
attempt to access beyond end of device
sdb: rw=0, want=4067027304, limit=1005568
attempt to access beyond end of device
sdb: rw=0, want=4067027304, limit=1005568
attempt to access beyond end of device
sdb: rw=0, want=4067027304, limit=1005568
attempt to access beyond end of device
sdb: rw=0, want=4067027304, limit=1005568
attempt to access beyond end of device
sdb: rw=0, want=4067027304, limit=1005568
attempt to access beyond end of device
sdb: rw=0, want=4067027304, limit=1005568
attempt to access beyond end of device
sdb: rw=0, want=4067027304, limit=1005568
attempt to access beyond end of device
sdb: rw=0, want=4067027248, limit=1005568
attempt to access beyond end of device
sdb: rw=0, want=4067027296, limit=1005568
attempt to access beyond end of device
sdb: rw=0, want=4067027304, limit=1005568
attempt to access beyond end of device
sdb: rw=0, want=4067027304, limit=1005568


This is the read out.
mwp
 
Posts: 3
Joined: Tue Jun 03, 2008 10:46 am

RE: USB will not mount

Postby alan » Tue Jun 03, 2008 7:49 pm

So, the problem source is not your Parsix settings but the USB device problem. Reformatting or Re-partitioning the device would probably fix the problem. At the moment, try to mount it manually:

Code: Select all
$ su
# mount -t vfat /dev/sdb /media/disk


Create /media/disk if it does not exist.
alan
Developer
Developer
 
Posts: 763
Joined: Tue Jan 25, 2005 7:13 am
Location: Santa Clarita, California

usb problem

Postby mwp » Sun Jun 08, 2008 1:30 am

Sorry for taking so long to get back. things came up. Some more fooling around shows that this one usb drive will not mount. My other usb drives will. Strange. it has never happened before.

Took the device and transferred all data from it. Then used gparted to clean and reformat to fat32. Still no love. Only happens onthis distro. Oh well, I have another.

Thanks for your help Allen. One suggestion. Could you improve your installer somehow to make it easier to mount multiple partitions such as /home. I can mount them after an install using gparted and then modifiying /etc/fstab, but real noobies are not going to be able to do that. Just a suggestion. Keep up the good work.

I am impressed with the ndiswrapper feature. I still had to use the terminal to get the .inf file loaded followed by loading the ndiswrapper module. But the parsix network configuration tool was very nice, spot on actually. Was able to use my usb antenna without a reboot. This was done on live cd before the install. Now that was very impressive. Only Sidux has been able to give me internet access through a usb dongle without a reboot first. Good show. Great work. I look forward to your future releases.

Thanks again. Sorry for the delay.

Cheers,
Michael

PS: almost forgot --there is some bug with the num lock. It wants to be on all the time.
mwp
 
Posts: 3
Joined: Tue Jun 03, 2008 10:46 am

RE: usb problem

Postby Daniele » Mon Jul 14, 2008 3:33 am

I had the same problem here, I got a long error message that I can't fully remember.
However after adding the Kanotix repo and dist-upgrading it, I solved it.
Daniele
 
Posts: 4
Joined: Mon Jul 02, 2007 9:47 am

RE: usb problem

Postby blix » Mon Jul 14, 2008 8:36 am

mwp wrote:Thanks for your help Allen. One suggestion. Could you improve your installer somehow to make it easier to mount multiple partitions such as /home. I can mount them after an install using gparted and then modifiying /etc/fstab, but real noobies are not going to be able to do that. Just a suggestion. Keep up the good work.

This helps you to setup different partition for /home. you can use it for other midifications as well.
Those who sacrifice liberty for security deserve neither.
Benjamin Franklin
blix
Forum Moderator
Forum Moderator
 
Posts: 115
Joined: Tue Jun 19, 2007 9:40 pm

Postby mandog » Tue Jul 15, 2008 10:24 am

Remember you must always unmount Usb devices before removing them, this also applies to windows. If you don't you run the risk of damaging the file stucture, and in some cases the Usb device as well, I use Usb devies all the time but like every thing else you only get what you pay for and the cheap ones do fail with very little use.
Parsix running AMD FX(tm)-6100 Six-Core Processor, Gigabyte mother board 8gb ram, Nvidia graphic card 1gb unboard ram, Plextor PX760, EPSON R300, 2x 500gb hds, sata+3x 500gb, 1x2tb Hardrives, 23" AOC monitor 1980X1080 Resolution
mandog
Forum Moderator
Forum Moderator
 
Posts: 483
Joined: Fri Jan 25, 2008 3:08 pm
Location: Peru

Postby lawmanuk » Tue Aug 19, 2008 12:56 pm

similar problem...

usb hdd works on pc1, but not pc2

both with parsix.

says does not have rights to mount on pc2

:(
lawmanuk
Parsix Lover
 
Posts: 148
Joined: Fri Aug 08, 2008 7:34 pm

Postby mandog » Tue Aug 19, 2008 3:38 pm

Try this
If you are using a external USB hd, make sure its not showing in the fstab file if it is then remove or use ## before the entry then when you plug it in it should read/write as it should
Parsix running AMD FX(tm)-6100 Six-Core Processor, Gigabyte mother board 8gb ram, Nvidia graphic card 1gb unboard ram, Plextor PX760, EPSON R300, 2x 500gb hds, sata+3x 500gb, 1x2tb Hardrives, 23" AOC monitor 1980X1080 Resolution
mandog
Forum Moderator
Forum Moderator
 
Posts: 483
Joined: Fri Jan 25, 2008 3:08 pm
Location: Peru


Return to Hardware Issues - English

Who is online

Users browsing this forum: Baidu [Spider] and 1 guest

cron