prefrences>mouse>left Hand does not work.

Discussions related to hardware issues, incompatibilities, drivers, etc.

Moderators: aysabzevar, mandog, alan, bkashaf, xet7, cmost, blix

prefrences>mouse>left Hand does not work.

Postby moonfriend » Sat Mar 07, 2009 10:12 am

I downloaded the latest release 2.0 r0 test2
in system>prefrences>mouse I changed the right-handed to left-handed but it didn't change anything.
I didn't have this problem in later versions of parsix.
do you think this might be a bug or hardware incompatibality?
I alo logged in as root and changed the setting but it didn't change.
moonfriend
 
Posts: 29
Joined: Tue Feb 05, 2008 6:04 pm

Postby moonfriend » Sun Mar 08, 2009 9:49 am

maybe I should ask the question in a different way:
does anybody else has this problem?
because not many people use left hand, this does not usually get considered.
so can anybody please test if they can make the mouse left handed?
tnx
moonfriend
 
Posts: 29
Joined: Tue Feb 05, 2008 6:04 pm

Postby Giovenale » Sun Mar 08, 2009 3:55 pm

Hi moonfriend, I'm left handed and I had this problem with many KDE distros (Sabayon Mini, DesktopBSD, many LiveCD), but never with Gnome.
These settings are stored in

/home/USERNAME/.gconf/desktop/gnome/peripherals/mouse/%gconf.xml

you can open it with text editor and modify the string

<entry name="left_handed" mtime="1234668533" type="bool" value="true">
</entry>

setting "true" as value.
Say me if it runs. :)
Giovenale
 
Posts: 28
Joined: Mon Sep 15, 2008 6:36 am

Postby eco2geek » Sun Mar 08, 2009 10:31 pm

Some playing around indicates that changing the mouse orientation to left-handed in the "Mouse Preferences" dialog changes the value "false" to "true" in that XML file. In other words using the Mouse Preferences dialog does the same thing as editing it manually as you suggest. (You can probably also change the value using gconf-editor.)

In any case, I can confirm that switching the mouse orientation from right-handed to left-handed has no effect on my (32-bit) computer either.

You could use "xmodmap" to switch orientation. For example, if you have a standard wheelmouse, you could use the command

xmodmap -e 'pointer = 3 2 1 4 5'

to switch the function of the left and right mouse buttons.
eco2geek
 
Posts: 55
Joined: Tue Apr 08, 2008 8:38 am
Location: Portland, Oregon

Postby moonfriend » Mon Mar 09, 2009 10:05 pm

thanx a lot
my system is 64 bit(just for the information for possible debuggers)
changing the
Code: Select all
 /home/USERNAME/.gconf/desktop/gnome/peripherals/mouse/%gconf.xm
did not change anything.
but
Code: Select all
xmodmap -e 'pointer = 3 2 1 4 5'
worked very well
moonfriend
 
Posts: 29
Joined: Tue Feb 05, 2008 6:04 pm

Postby alan » Tue Mar 10, 2009 3:25 am

Again, another GNOME 2.24 glitch! Ubuntu Intrepid has the same issue.
alan
Developer
Developer
 
Posts: 763
Joined: Tue Jan 25, 2005 7:13 am
Location: Santa Clarita, California


Return to Hardware Issues - English

Who is online

Users browsing this forum: No registered users and 1 guest